Topologi
Objective.
Mempelajari konfigurasi membuat Jaringan MPLS VPN dengan menggunakan Static Routing Pada koneksi Router PE dan CE
Router PE 1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.1 255.255.255.0
mpls ip
!
interface Ethernet0/1
ip vrf forwarding bri.kiri
ip address 10.10.10.1 255.255.255.252
!
interface Ethernet0/2
ip vrf forwarding bca.kiri
ip address 10.10.10.1 255.255.255.252
!
router ospf 1
router-id 1.1.1.1
network 1.1.1.1 0.0.0.0 area 0
network 12.12.12.1 0.0.0.0 area 0
!
router bgp 65000
bgp log-neighbor-changes
redistribute connected
redistribute static
neighbor 3.3.3.3 remote-as 65000
neighbor 3.3.3.3 update-source Loopback0
!
address-family vpnv4
neighbor 3.3.3.3 activate
neighbor 3.3.3.3 send-community extended
exit-address-family
!
Router PE2
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Ethernet0/0
ip vrf forwarding bri.kanan
ip address 10.10.10.5 255.255.255.252
!
interface Ethernet0/1
ip address 23.23.23.3 255.255.255.0
mpls ip
!
interface Ethernet0/2
ip vrf forwarding bca.kanan
ip address 10.10.10.5 255.255.255.252
!
router ospf 3
router-id 3.3.3.3
network 3.3.3.3 0.0.0.0 area 0
network 23.23.23.3 0.0.0.0 area 0
!
router bgp 65000
bgp log-neighbor-changes
neighbor 1.1.1.1 remote-as 65000
neighbor 1.1.1.1 update-source Loopback0
!
address-family vpnv4
neighbor 1.1.1.1 activate
neighbor 1.1.1.1 send-community extended
exit-address-family
!
Router P
interface Loopback0
ip address 2.2.2.2 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.2 255.255.255.0
mpls ip
!
interface Ethernet0/1
ip address 23.23.23.2 255.255.255.0
mpls ip
!
router ospf 2
router-id 2.2.2.2
network 2.2.2.2 0.0.0.0 area 0
network 12.12.12.2 0.0.0.0 area 0
network 23.23.23.2 0.0.0.0 area 0
!
untuk router CE konfigurasikan ip addressnya saja, sekarang mari kita mulai konfigurasinya, pertama mari kita buat static route default di sisi CE nya
setelah membuat routing static pada router CE sekarang kita buat routing static pada Router PE