Topologi
Objective. untuk aggregation ini fungsinya sama saja dengan summarization pada ospf dan eigrp yaitu mengelompokan beberapa host kedalam sebuah subnet
Router 1
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
ip address 11.11.11.11 255.255.255.255
!
interface Ethernet0/0
ip address 12.12.12.1 255.255.255.0
router eigrp 10
network 1.1.1.1 0.0.0.0
network 12.12.12.1 0.0.0.0
router bgp 123
bgp log-neighbor-changes
network 11.11.11.11 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 123
neighbor INTERNAL update-source Loopback0
neighbor 2.2.2.2 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
Router 2
interface Loopback0
ip address 2.2.2.2 255.255.255.255
interface Loopback1
ip address 22.22.22.22 255.255.255.255
interface Ethernet0/0
ip address 12.12.12.2 255.255.255.0
interface Ethernet0/1
ip address 23.23.23.2 255.255.255.0
interface Serial1/0
ip address 24.24.24.2 255.255.255.0
serial restart-delay 0
router eigrp 10
network 2.2.2.2 0.0.0.0
network 12.12.12.2 0.0.0.0
network 23.23.23.2 0.0.0.0
router bgp 123
bgp log-neighbor-changes
network 22.22.22.22 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
redistribute eigrp 10 metric 10
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 123
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 3.3.3.3 peer-group INTERNAL
neighbor 24.24.24.4 remote-as 4
neighbor 24.24.24.4 next-hop-self
!
Router 3
interface Loopback0
ip address 3.3.3.3 255.255.255.255
!
interface Loopback1
ip address 33.33.33.33 255.255.255.255
!
interface Ethernet0/1
ip address 23.23.23.3 255.255.255.0
!
router eigrp 10
network 3.3.3.3 0.0.0.0
network 23.23.23.3 0.0.0.0
!
router bgp 123
bgp log-neighbor-changes
network 33.33.33.33 mask 255.255.255.255
neighbor INTERNAL peer-group
neighbor INTERNAL remote-as 123
neighbor INTERNAL update-source Loopback0
neighbor INTERNAL next-hop-self
neighbor 1.1.1.1 peer-group INTERNAL
neighbor 2.2.2.2 peer-group INTERNAL
!
Router 4
interface Loopback0
ip address 4.4.4.4 255.255.255.255
!
interface Loopback1
ip address 44.44.44.44 255.255.255.255
!
interface Ethernet0/0
no ip address
shutdown
!
interface Ethernet0/1
no ip address
shutdown
!
interface Ethernet0/2
no ip address
shutdown
!
interface Ethernet0/3
no ip address
shutdown
!
interface Serial1/0
ip address 24.24.24.4 255.255.255.0
serial restart-delay 0
!
interface Serial1/1
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/2
no ip address
shutdown
serial restart-delay 0
!
interface Serial1/3
no ip address
shutdown
serial restart-delay 0
!
router bgp 4
bgp log-neighbor-changes
network 4.4.4.4 mask 255.255.255.255
network 24.24.24.0 mask 255.255.255.0
network 44.44.44.44 mask 255.255.255.255
neighbor 24.24.24.2 remote-as 123
!
oke kita mulai konfigurasinya, pertama kita buat terlebih dahulu interface loopback untuk kita aggregation nantinya
setelah itu kita advertise ke routing BGP
setelah kita advertise maka subnet subnet tersebut sudah siap di aggregate, sekarang mari kita coba aggregate subnet subnet tersebut
disini coba saya aggregate subnet subnet tersebut menjadi /24, sekarang mari kita lihat routing tabelnya saat ini
terlihat diatas jika ip sudah dikelompokan namun masih terlihat terpisah untuk mengelompokannya kita tambahkan summary-only pada command aggregationnya
oke sekarang mari kita lihat kembali routing tabelnya
oke bisa anda lihat jika subnet diatas sudah dikelompokan ke dalam network /24, untuk aggregation sendiri kita bisa konfigurasikan ip apa saja yang bisa diakses dan mana yang tidak, oke kita mulai saja konfigurasinya, pertama kita
lalu kita buat route-map nya
lalu kita advertise route-map tersebut kedalam bgp
lalu kita lihat ip bgp nya di
bisa dilihat jika diatas untuk ip 1 dan 2 sudah berstatus suppressed, untuk tahap terakhir mari kita cek tabel routing di router lain apakah masih terbaca ip ip yang suppessed atau tidak
oke bisa anda lihat jika ip ip yang tadi kita blok sudah tidak muncul kembali di routing tabel router 1, begitulah konfigurasinya sekian selamat mencoba wasalamualaikum wr wb